Compatibility

Google Chrome

Tested versions

  • Version 66.0.3359.181 (Official build) (64bit)
  • Version 70.0.3538.67 (Official build) (64bit)
  • Version 70.0.3538.102 (Official build) (64bit)

Firefox

Tested versions

  • Version 47.0
  • Version 63.0

Internet Explorer & Edge

For now it isn't possible to use CzechIdM product with IE versions older than IE11.

Tested versions

  • IE 11,
  • IE 11.345.17134.0
  • EDGE 84.0.522.59

Known issues

  • Icons and fonts do not work if your system or IE has downloading of fonts disabled (this is a security setting). You can enable it in IE or system settings (or through the AD domain GPO). See following pictures for how to do that: System settings or IE settings. Article about it.
  • Calendar in approval tasks overlaps the bottom of the page. A scroll bar appears but when working on touchpad without gesture scrolling support there is no way to scroll. As a workaround you can type the date into the text field without using the calendar. This is fixed in newer versions of Edge based on Chromium core.

Apple Safari

  • Safari 11.x

Our product is primary developed and tested on Apache Tomcat application server. We recommend to use this application server.

Apache Tomcat

Apache Tomcat is currently tested on these versions:

  • 8.0.x
  • 8.5.x
  • 9.0.x (recommended)

You can download the Tomcat from its official webpage.

CzechIdM 10 and higher versions are not compatible with Apache Tomcat 7.

Known issues

  • We don't register any issues with this application server.

JBoss WildfFly

JBoss WildFly isn't currently fully tested, but main functionality works. JBoss WildFly tested versions:

  • 10.0.0 (Bug with date time format exception.)
  • 11.0.0,
  • 12.0.0.

You can download the application server from here.

Known issues

  • version 10.0.0 has bug with different versions of fasterxml library which leads to date time format exception. The solution is to replace JBoss' fasterxml library with a newer one. (We recomend to use fasterxml library from JBoss WildFly 12.0.0),
  • Loading connectors for ACC module is supported since CzechIdM 8.1.0 onwards.

PostgreSQL

PostgreSQL is our first supported databases. CzechIdM application contains all required flyway scripts for run the database.

Tested versions:

  • 9.6
  • 10
  • 11
  • 12

Known issues

  • We don't register any issues with the PostgreSQL database.

Microsoft SQL Server

Microsoft SQL Server is another supported database. CzechIdM application contains all required flyway scripts to manage the tables inside database. Please follow these instructions to setup CzechIdM with MsSQL database.

Tested versions:

  • SQL Server 2017, version 14, build 14.0.3294.2

Knows issues

  • Filtering by fulltext ID's doesn't work correctly. For example, Events agenda and filter by ownerId and Id (the ownerType filtering works).
  • (only CzechIdM versions older than 10.1) Automatic roles by attribute work in MsSQL only when using shorttext (String).